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An application to print folder (directory) listings from Windows 95 (© Microsoft) as a catalogue of the files 
contained in the folder. The catalogue may be printed or saved to a text file, and contiguous selections 
may be printed or copied to the clipboard. The font style and page layout is adjustable.



G.N. & J.L. Kerkin
G.N. & J.L. Kerkin are Process Engineering and Information Consultants operating out of New Zealand 
and providing process (chemical) engineering and process information services to the food and other 
process industries.

The partnership specialises in the economics of dairy processes and offers a service in modelling of costs
of operation, establishment of development strategies, computer based process utilities and databases, 
process engineering design and process development. It has extensive experience in a variety of 
chemical process industries, chemical engineering education and the development of computer programs
and computer based systems.



Disclaimer

THIS APPLICATION IS USED ENTIRELY AT THE USER'S RISK.

The author and copyright    holders accept no liability for any damage whatsoever which may result from 
the proper or improper use of this application.

This software and the accompanying files are sold "as is" and without warranties as to performance or 
any other warranties whether expressed or implied. No warranty of fitness for a particular purpose is 
offered.



License Agreement
The following terms and conditions should be read carefully before using this application. Use of this 
application indicates acceptance of this License Agreement.

This application is not free. The shareware version may be used for evaluation purposes for 30 days. 
Thereafter continued use of this application without registration constitutes a violation of this license 
agreement.

Shareware Version
The shareware version of Folder Catalogue may be used for evaluation purposes without charge for a 
period of 30 days. Continued use beyond the 30 day evaluation period without payment of the appropriate
registration fee constitutes a breach of this License Agreement and violation of New Zealand and 
international copyright laws.

Copies of the shareware version of the Folder Catalogue software and documentation may be copied in 
unmodified form and distributed freely provided that no charge is made is made for any copies so 
distributed except that a reasonable and nominal charge may be made for recording media.

Registered Version
This License Agreement allows the use of one registered version of Folder Catalogue installed on a 
personal computer or workstation provided that installation of the software shall be such that it can not be 
used by more than one person simultaneously.

A registered version of Folder Catalogue may be installed on a network and accessed by a number of 
users provided that an individual license is obtained for each workstation which can access the software 
simultaneously.

This License Agreement forbids the copying and distribution of a registered version of Folder Catalogue 
without the purchase of additional licenses for each copy made. Such copying in the absence of 
additional licenses constitutes a breach of this License Agreement and violation of New Zealand and 
international copyright laws.

Governing Law
This agreement is governed by the laws of New Zealand



Copyright for Folder Catalogue is held by Gary N. Kerkin and G.N. & J.L. Kerkin 1996



Startup
Folder Catalogue may be launched from a shortcut icon, by double clicking on its file name (fldcatxx.exe, 
where xx is 16 or 32) in Explorer or My Computer (Windows 95) of File Manager (Windows 3.1), or from 
Start/Run (Windows 95) or File/Run (Windows 3.1).

When it is launched a check is made to see if the application has been registered and if not a registration 
dialog box is displayed. The application may continue to be used with full functionality but if use is 
continued beyond the trial period it should be registered to avoid copyright and License infringements. If a
license number has been obtained it should be entered at this time.

The main window will establish with the preview screen blank (displaying only an instruction message) 
and with only the Preview and Page Setup buttons activated. The Drive, and Folder boxes will be set to 
the last access made by the application and the Page Setup parameters, including font and colours will 
be those last used by the application.



Registration

A registration licence number may be obtained by copying the form below 
and emailing, faxing, or snailmailing it to:

G.N. & J.L. Kerkin
428 Thames Street,
Morrinsville,
New Zealand.

Fax +64 & 889 3028
Email gkerkin@kerkin.co.nz; 100250.1220@compuserve.com.

Alternatively the program fcregxx.exe may be executed (where xx = 16 or 32).

CompuServe subscribers may register through the Shareware Registration
facility in CIS (GO SWREG) searching for number 11258 for the 16 bit
version (Windows 3.1) or number 11257 for the 32 bit version (Windows 95).

Please note the registration by email and payment as detailed below offers
the option of obtaining multiple licenses of Folder Catalogue, and copies
of Folder Catalogue on 3.5" Disks. However registrants using CompuServe 
can only order a single license and will automatically receive a disk copy 
of Folder Catalogue. The total cost for a license if ordered through 
CompuServe is $US30.

--------------------------------------------------------------------------
                    ORDER FORM
                  FOLDER CATALOGUE

Name                   ___________________________________________

Name for Registration  ___________________________________________

Organisation           ___________________________________________

Address                ___________________________________________

                       ___________________________________________

                       ___________________________________________

City                   ___________________________________________

State                  ___________________________________________

Zip                    ____________________

Country                ___________________________________________

Work Telephone         ____________________

Home Telephone         ____________________

Facsimile              ____________________

Email Address          ___________________________________________

Please indicate the number of Licenses required, the number of
disk copies and the platform required:



Number of Licenses of Folder Catalogue  ________

Number of 3 ½" Disks Required           ________

Platform: Windows 95 _____   Windows 3.1 _____   

Payment Method (indicate which method):

Bank Draft___    Visa Card___  Mastercard___  American Express___

Credit Card Number      ______________________________

Cardholder's name ______________________________

Expiry Date __/__

Signature (for fax or mail) __________________________

Payment Schedule (US Dollars):

               Copies              Licences(each)
                 1                   $25.00 
                 2                   $24.00  
                 3                   $22.00   
                 4                   $20.00   
               5 - 10                $17.50 
                10+                  $15.00 

Any number of disk copies up to maximum of one disk copy per license may be 
ordered at a cost of $US2.00 per copy.

Payment Tendered:

Quantity              Item                Cost (each)      Amount

 _____   Licenses of Folder Catalogue @   __________     _________

 _____   Disk copies @ $2.00              __________     _________

         Postage and Packing ($US3.00 if disks required) _________

         TOTAL                                           _________

The total amount in US Dollars will be converted to NZ Dollars at the
conversion rate pertaining on the day the order is received. Because 
currency conversions fluctuate rapidly there may be some discrepancies 
between the amount on this order and the amount debited to a credit card.

A bank draft must be made out to G.N. & J.L. Kerkin and payable in 
Morrinsville, New Zealand. The value must be in US Dollars.

A license number will be forwarded by the most effective means upon 
receipt of registration. (Email, fax or snailmail, in that order). 
If disk copies have been requested they will be forwarded by Airmail.



Selecting a folder
Select the combination of drive and folder to access the list of files you wish to display.

By default the last folder selected when the application was last run will be selected on startup. 
Selecting another folder will clear the preview screen.



Selecting a file type
In the file type box either select one of the default file types or type in the extension required (eg *.txt)

The following groupings are available in the list box. Any other combination, separated by semicolons 
may be used as indicated below.

*.*
*.exe;*.com;*.bat;*.sys 
*.dll;*.vxd;*.drv;*.386
*.jpg;*.gif;*.pcx;*.tif
*.bmp;*.dib
*.tga;*.pc*;*.rle
*.txt;*.prn;*.ans;*.asc
*.doc;*.dot
*.xl*;*.wk*
*.zip;*.lzh;*.arj;*.arc
*.tga;*.pc*;*.rle

By default *.* is selected on startup.

Changing the file type will clear the preview screen.



Selecting File Attributes
Check or uncheck    the file attribute boxes as required. By default all boxes are checked on startup.

Changing any of the attributes will clear the preview screen.



Previewing a Folder Catalogue
To preview the catalogue of files of selected type, attribute, in a selected folder, click on the Preview 
button, or select Preview from the File menu.



Printing a Folder Catalogue
Printing a folder catalogue is only possible when the catalogue contents are displayed in the preview 
screen.

Click on the Print button or select Print from the File menu. 

When the Printer dialog box is displayed select the appropriate printer and if a only a selection is to be 
printed, click the Selection radio button. Click OK. Another dialog box will request a page header, 
suggesting either the folder path, or the previously entered header as default. Accept this or enter another
header as desired. Pressing the cancel button will stop a header being printed for this one print run. Page 
numbers are still printed.



Saving a Catalogue to File
To save a folder catalogue to file click on the Save button or select Save command from the File menu.

The File Save As Dialog is displayed. Enter or select a name and select a folder and press OK.

The folder catalogue data is copied to the selected file as comma delimited text which may be imported 
into a spreadsheet or database and parsed accordingly.



Comma delimited text is text in which the words or phrases (fields) are separated by commas allowing 
simple parsing in spreadsheets or databases.



Selecting An Individual File
Click on a line in the preview screen. The selected line will be displayed in a contrasting colour. If a 
previous line has been selected, select a new line replaces the current selection. Contiguous lines may 
also be selected.

Selecting a file activates the copy button and command (Edit menu).



Selecting a Group of Contiguous Files
Click on the first file in the group in the preview screen. Move the pointer to the last file in the group, 
scrolling the preview screen as required, and hold Shift while clicking on the last file. The group can be 
selected in either direction

The whole directory can be selected using the Select All command (Edit menu)



Copying to the Clipboard
Click on the Copy button or select the Copy command on the Edit menu to copy the selected file or group 
of files to the clipboard.

The selected information is copied as comma delimited text which can be copied into a spreadsheet or 
database and parsed accordingly.



Menus
File    
Edit    
Help    

 



File Menu
Preview    
Save    
Page Setup    
Print    



Edit Menu
Copy    
Select All    



Help Menu
Help    
About    



Toolbar

Save    
Print    
Copy    
Page Setup    
Preview    
Help    



Preview

Writes information about selected files from the selected folder into the preview screen in the format 
selected for printing.



Save

Saves the selected folder and file information to a disk file as comma delimited text.



Page Setup

Displays a dialog box which allows margins, column widths and font to be selected. Only fonts which can 
be printed will be displayed. Font colour may also be selected and will be displayed on screen. Colour has
no effect with black and white printers.

Margins may be set as desired up to a maximum of about 2 inches or 5 cm.

The width of the file name, file size and time & date columns may individually adjusted. The units are 
percentages of the width on the page available for printing. The file name column may be a minimum of 
20% of the available width and a maximum of 70%. When the file name column is adjusted the other two 
columns are allocated one half each of the remaining width. The minimum for each column is 15% of the 
available width. When one of the file size or the time & Date columns are adjusted the other column is 
automatically adjusted to the balance of the width after the file name and the column just altered have 
been allocated subject to minimum widths.



Print

The folder catalogue displayed in the preview screen may be printed by clicking on the Print Button or 
selecting the Print command on the File menu. 

The Printer Dialog is displayed and both printer and paper may be selected.

If a single file, or a block of files is selected, the selection only may be printed. A number of copies may be
set.

When the print dialog is completed, a Header to be printed on each page is requested. A default header 
which is either the current folder path, or the last header entered in the current session is displayed. This 
may be accepted (by pressing OK) or another Header entered in the text box. Pressing the Cancel button 
causes an empty string to be printed as a header.



Copy

If a folder catalogue is displayed in the preview screen and if one or more files has been selected, clicking
on the Copy button, or selecting the Copy command on the Edit menu will copy the information about the 
selected file(s) to the clipboard as comma delimited text.



Select All
Selecting the Select All command on the Edit menu selects all the files in the folder catalogue displayed in
the preview screen.



Help

Clicking the Help button, or selecting the Help command on the Help menu displays this help file.



About
Selecting the About command on the Help menu displays the About Folder Catalogue Dialog.



Shortcut Keys
Folder Catalogue recognises all relevant Windows editing keys.

The following keyboard shortcuts may also be used.

Copy Ctrl+C
Help F1
Page Setup Ctrl+G
Preview Ctrl+W
Print Ctrl+P
Save Ctrl+S
Select All Ctrl+A




